First Last Prev Next    No search results available      Search page      Enter new bug
Bug#: 61
Product:
Component:
Status: RESOLVED
Resolution: FIXED
Assigned To: Matthew Allen <fret@memecode.com>
Hardware:
OS:
Version:
Priority:
Severity:
Reporter: Matthew Allen <fret@memecode.com>
Add CC:
CC:
Remove selected CCs
URL:
Summary:

Attachment Type Creator Created Size Actions
Create a New Attachment (proposed patch, testcase, etc.) View All

Bug 61 depends on: Show dependency tree
Show dependency graph
Bug 61 blocks:

Additional Comments:







View Bug Activity   |   Format For Printing   |   XML   |   Clone This Bug


Description:   Opened: 2005-11-22 00:38
groupware McServer imap doesn't delete .eml files from the serverfolder.
Causing double messages to appear in the imap folder view in Scribe.
Imap folder in Scribe shows the same amount of emails as emls in the folder, 
only all of them with content of an email stored in the folder that has not 
been deleted.

------- Comment #1 From Matthew Allen 2005-11-22 00:38:39 -------
*** Bug 51 has been marked as a duplicate of this bug. ***

------- Comment #2 From Matthew Allen 2005-11-22 03:12:38 -------
When you right click on the folder in Scribe and go "Properties" you should
have
a "Expunge" button and a number of deleted messages. If you hit "Expunge" it
will delete the messages flagged for deletion. At this point the files should
disappear off the server.

Can you confirm that is the case?

If so you should close this bug, as it is working as intended. This is simply
how the IMAP protocol works.

------- Comment #3 From exosceleton 2005-11-22 10:00:44 -------
Yes and no.
you are right, the expunge action removes the eml.

but some bugs do remain.
after an expunge the eml is deleted, but the email remains in the imap folder 
of clients other then the one that deleted. viewing an other folder, and then 
back to the imap folder still shows the deleted email. (i tried this because it 
does work for displying new imap emails).
only a reconnect will remove the email from the imap folder.

allso the client that puts an email in the imap folder cannot delete this email 
untill after a reconnect.
when clicking the delete button on a just copied email, the  email is put in 
the trash folder, but it stillremains in the imap folder. (sometimes server 
crashes)

in my opinion (without knowing the details of the code or protocol) there 
should be more information exchanges between client and server after every 
action. If i perform a reconnect after every action taken on the imap folder 
there are no problems.
(except that another client cannot know that something has changed so is not 
aware that a reconnect is required)

my 2 cents,
exo

------- Comment #4 From exosceleton 2005-11-22 10:02:10 -------
should i make some screen recordings?

------- Comment #5 From Matthew Allen 2005-11-22 10:06:49 -------
Ok, I'll take these comments into consideration when I look at it next. I'm
still digesting your comments about the POP server.

------- Comment #6 From Matthew Allen 2005-11-22 21:21:36 -------
Some of these issues are actually problems in the Scribe codebase not on the
server. But I've made a number of fixes there for not being able delete new
messages and deleted messages coming back from the dead.

For issue of other clients not getting notifications of deletes and new messages
I will create a new bug as it's a separate issue.

------- Comment #7 From Matthew Allen 2005-11-22 21:45:09 -------
I've made a new build of Scribe with some IMAP fixes here:
    http://www.memecode.com/temp/inscribe-win32.exe

And you can grab groupware v0.81 from the main site.

------- Comment #8 From exosceleton 2005-11-23 08:13:03 -------
scribe and server crash on expunge
new scribe build, 0.81 win2k

crash data scribe (note scribe folder is under server folder)
/////////////////////////////////////////////////////////////////////
Unhandled Exception
  Code: c0000005
  Description: EXCEPTION_ACCESS_VIOLATION

Call stack:
------------------------------------------------------------------
0048DB92: E:\Memecode Groupware\scribe2\Scribe.exe
1001AE25: E:\Memecode Groupware\scribe2\Lgi.dll Offset: 0x930 (GView::OnEvent)
77E12CA8: C:\WINNT\system32\USER32.DLL Offset: 0x444 (GetSysColor)
1001F98F: E:\Memecode Groupware\scribe2\Lgi.dll Offset: 0x191 (GDialog::DoModal)
0042DF15: E:\Memecode Groupware\scribe2\Scribe.exe
------------------------------------------------------------------

////////////////////////////////////////////

crash data server:
////////////////////////////////////
Call stack:
------------------------------------------------------------------
0041C189: E:\Memecode Groupware\McServer.exe
------------------------------------------------------------------

Unhandled Exception
  Code: 80000003
  Description: EXCEPTION_BREAKPOINT

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

Unhandled Exception
  Code: 80000003
  Description: EXCEPTION_BREAKPOINT

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

Unhandled Exception
  Code: 80000003
  Description: EXCEPTION_BREAKPOINT

Call stack:
------------------------------------------------------------------
------------------------------------------------------------------

//////////////////////////////

------- Comment #9 From Matthew Allen 2005-11-24 03:47:59 -------
I've moved the crashes to Bug #63.

This should be fixed in the exo2 builds I sent you links for.

------- Comment #10 From exosceleton 2005-11-24 11:03:31 -------
exo2 build still chraches, but ill move to the new bug number

First Last Prev Next    No search results available      Search page      Enter new bug