Forum Post
Index > Scribe > Linux Test 27 observations

Author/Date Linux Test 27 observations
Mike
26/05/2003 8:32pm
You knew this was coming right? ;)

It's looking awesome so far. I only found one problem so far, although I haven't used it all that much.

I have the Scribe icon in KDE's system tray, which is just awesome. However, there's are two major problems with it.

1) When I open the context menu using the right mouse button on the system tray icon, I can't close the menu. The icon is now hidden. The only ways out are to quit Scribe or to select an email address and then cancel the message. The menu is visible even when I change workspaces.

2) When I open a sub-menu (I organise my email addresses by country), the sub-menu that pops up hides the main menu, so I can't continue to browse sub-menus, nor can I close it. If that makes sense.

Awesome work again! :)
fReT
26/05/2003 8:38pm
Firstly to cancel the menu, I click anywhere outside it and it goes away, are you trying something else?

At the moment, the sub menu pops up in the normal place, but moved onscreen. This should be changed to mirror to the opposite edge. This hasn't been a showstopper for me so it's low priority. I guess it depends on the width of the contents and the various positions involved. I'll keep it in mind next time I'm working on the Linux build.
Mike
26/05/2003 8:52pm
Weird, now the menu does close when I click outside. It didn't before.
fReT
26/05/2003 9:57pm
There may be another thing that has to happen to get the menus confused... which then causes them to not close properly, but at least when you first start up they should close properly.

There was an issue in eariler builds that caused the menus not to close when clicking outside them. I fixed that recently.
Mike
27/05/2003 12:31am
I'm still having the problem where I can't use the menus after leaving Scribe running idle for a few hours. It just won't respond to any mouse clicks. I wish I could give more detail than that, but that's the best I can do. :(

Thanks
fReT
27/05/2003 12:50am
Does the main window repaint when it's re-exposed?

I'm trying to work out whether it's hung, or just not accepting clicks.

Eventually I'll see this happen to me and I'll be able to find out whats going on. So far I've had it running for a few hours at a stretch, but not that long. Because I'm constantly shutting it down to change something in the code ;)
Mike
27/05/2003 10:24am
From memory (this was last night) it did re-paint. I'll try to verify that and see if it still lets me click icons and send emails etc....

Cheers
Mike
27/05/2003 10:25am
One more thing. When I open a menu, the mouse icon changes to a clock. I think (IMO) it should stay as a mouse pointer.
Mike
27/05/2003 12:29pm
Ok, it happened again. Scribe is still being re-drawn. When I move the mouse over the icons they are highlighted etc. But it won't respond to mouse input.
Mike
27/05/2003 1:28pm
I run Scribe from a bash shell. I'm getting a steady stream of this line, approximately 3 a second:

QApplication::OnEvent: SelectionRequest received but I have no ClipText.

Cheers
Mike
27/05/2003 1:49pm
Hmmm, Scribe segfaulted when I clicked on a message in the Trash. I usually delete half of the trashed messages a week, so I can keep the more recent ones in case I need to undelete them due to a mistake. I re-ran Scribe and tried the same thing again and it worked fine.

I hope these observations are more helpful than annoying. :)
fReT
27/05/2003 7:19pm
No, these comments are helpful.

So it's not hanging. I think I saw the same thing last night, but I didn't get to fix it. The menus did stop responding.

There are fixes in the latest release regarding d'n'd that might fix these sort of issues. Although there may be other places that cause the same problems as well.
Mike
27/05/2003 10:15pm
Alrighty. Downloading and I'll try to post some observations later or tomorrow.

Thanks
Mike
27/05/2003 10:17pm
Woah not good!

Segmentation fault:

Error: WaitForExpose() timeout!!

I was trying to re-size the preview pane. It wouldn't let me release the preview pane when I clicked the mouse button. If that makes sense.
Reply