Forum Post
Index > Scribe > PGP problem

Author/Date PGP problem
netean
19/06/2003 10:28am
hmm having a bit of a problem.

problem 1:
when I try to import your key (matthew) into Winpt (to add my keyring) it crashes GPG (v1.2.2)

2nd problem - probably related?
I'm not entirely clear how to use the plugins. I have experimented with loading one at a time and both, but when I create a new message (to you)
none of the PGP icons actually seem to work.

Clicking the "+add key" gives the dialog box

gpg: No valid Openpgp data found
gpg: total no processed: 0


Clicking on Encrypt, Sign and encrypt+Sign gived the dialog "No Extension"


I'm currently running WinPT (0.7.96)
therefore I have gpg installed (C:\Program Files\Windows Privacy Tools\GnuPG\gpg.exe) -also on path
and I have keys to use (several in fact, depending on my email address I'm sending from: Work, personal, etc)


(running windows xp pro sp1)
latest build of scribe
latest plugins
Winpt (0.7.96)
GPG 1.2.2
fReT
19/06/2003 8:17pm
The "no extension" issue is just a bug, which I've now fixed, see the v0.15 release of the GPG plugins.

As for importing my key into WinPT and GPG crashing, thats not anything to do with my software. You might want to try reporting that to the GPG people.

The add button takes the text in the current email and assumes that there is a public key in there somewhere and gives it to GPG to add to the keyring. If no valid public key exists in the input text then thats the sort of error I'd expect to see. Otherwise it's a bug in GPG most likely. I tested it and it's working as I expect.
netean
20/06/2003 6:51am
thanks for that. Will have another go

If anyone else has added you (matthew) to their pgp keyrings, could they let me know. whilst I'm sure it's a problem with gpg, or winpt, it might be helpful to know what to submit to them in a bug report.?
Reply