Forum Post
Index > Scribe > Unable to send mail from outbox

Author/Date Unable to send mail from outbox
murrshot
23/06/2003 2:13pm
Not sure if its my email provider or iscribe but whenever I try to send an email thats in the outbox I get the following message that I took from the log:

220 www.fastmail.fm ESMTP
HELO murrshot@ftml.net
250 www.fastmail.fm
MAIL FROM:
250 Ok
RCPT TO:
554 : Relay access denied
DATA
554 Error: no valid recipients
HELO murrshot@ftml.net
250 www.fastmail.fm
MAIL FROM:
250 Ok
RCPT TO:
554 : Relay access denied
DATA
554 Error: no valid recipients



I tried replying to 2 different recipients with the same result. I did a test message to myself and was able to reply to it, dunno what to check. I'm using the current test 32 version of i.scribe. One last thing, I know some people dont like HTML in email, but every now and then I like to throw a little smiley face emoticon at the end of my messages, only when I'm teasing friends tho'. Any chance for a plugin that will let you insert html? This is a great program, thanx for any help!
fReT
23/06/2003 7:48pm
What happens when you use your fastmail address in the "From" line?

Make sure in the send tab of your account you have ESMTP authentication switched on, and your user/pass in there.
murrshot
24/06/2003 8:52am
Here is what I get with ESMTP checked:

220 www.fastmail.fm ESMTP
EHLO murrshot@ftml.net
250-www.fastmail.fm
250-PIPELINING
250-SIZE 10120000
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN OTP
250-AUTH=LOGIN PLAIN OTP
250-XVERP
250 8BITMIME
AUTH LOGIN bXVycnNob3RAZnRtbC5uZXQ=
535 Error: authentication failed

This is what I get with it unchecked:

220 www.fastmail.fm ESMTP
HELO murrshot@ftml.net
250 www.fastmail.fm
MAIL FROM:
250 Ok
RCPT TO:
504 : Sender address rejected: need fully-qualified address
DATA
554 Error: no valid recipients


I checked the from box and it looks to be correct, it displays this:

"Marcus Murray" <murrshot@ftml.net>

fReT
24/06/2003 8:53pm
Alright, ESMTP appears to be broken. Something which shouldn't be too hard to address quickly.

Fastmail does require authentication according to their FAQ.
murrshot
24/06/2003 10:03pm
Thanx for looking into it. I also just purchased InScribe to show my appreciation.

Oh, wish list, any chance to be able to attach gifs, man, I can't live with my smiley emoticons....
fReT
25/06/2003 11:03am
I've reworked the ESMTP authentication code, although I can't test that it works with fastmail, because only have the free account.

I did test the "LOGIN" auth type with Mercury mail server installed locally. But I think fastmail uses the "PLAIN" login type which I have implemented, I'm just not sure if it's correct.

I guess we'll find out when I release it eh!
murrshot
26/06/2003 9:51am
Yo, I just tried it from the inscribe test 33 version, checked the ESMTP w/username/password and the message sent!
Thankz for the fix!

220 www.fastmail.fm ESMTP
EHLO murrshot
250-www.fastmail.fm
250-PIPELINING
250-SIZE 10120000
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN OTP
250-AUTH=LOGIN PLAIN OTP
250-XVERP
250 8BITMIME
AUTH PLAIN AG11cnJzaG90AGQwMGthcHAq
235 Authentication successful
MAIL FROM:
250 Ok
RCPT TO:
250 Ok
DATA
354 End data with .
250 Ok: queued as C478117BD8
QUIT
221 Bye
murrshot
26/06/2003 12:57pm
Oh, not trying to be greedy, but one more thing. Is it possible to be notified of new mail, but to leave the mail on the server without downloading the new mail? If not, maybe another something for the wish list. {;0)
fReT
26/06/2003 7:46pm
Great! Thanks for the bug report.

Preview mail before download is already on the todo list.
hoemme@lycos.de
04/07/2003 6:40am
there is a problem with the linux-version to work with ESMTP. The password-field is greyed - Why? I need The ESMTP-Function to login!

The version under win32 works fine, without any problems!

By the way, its a great idea to make a crossEmailClient! Thank You!
fReT
05/07/2003 2:47am
I'll do something about that for the next release.
Reply