Forum Post
Index > Scribe > Test44 bug in pop authentication

Author/Date Test44 bug in pop authentication
lsoltero
09/12/2003 1:45am

Hi Matthew,

There is a bug in the pop authentication in iScribe.

First configure iScribe with the correct pop password.
then check and receive e-mail. Everything works great.
Here is the pop log on the server

POP: 09/12/2003 00:18:12-Spawning server thread for socket [2648]..
POP: Sending 'service ready' to receiver on socket [2648]..
POP: (State=1) on socket [2648] Got USER test

POP: sent OK to USER test on socket [2648]..
POP: (State=1) on socket [2648] Got PASS
POP: sent OK to PASS on socket [2648]..
POP: (State=2) on socket [2648] Got STAT

POP: Collecting file list from E:\XGATE\XGATE\spool\test\*.mail..
POP: STAT result on socket[2648]=+OK 2 302

POP: (State=2) on socket [2648] Got LIST 1

POP: LIST result on socket [2648]=+OK 1 147

POP: (State=2) on socket [2648] Got RETR 1

POP: Sending +OK to start mail for remote on socket [2648]..
POP: Sending mail data [1070950802.2727_0.gmn.gmn-usa.comS=159.Mail] to remote on socket [2648]..
POP: EOD sent to remote on socket [2648], sendTCP() RC=0..
POP: (State=2) on socket [2648] Got LIST 2

POP: LIST result on socket [2648]=+OK 2 155

POP: (State=2) on socket [2648] Got RETR 2

POP: Sending +OK to start mail for remote on socket [2648]..
POP: Sending mail data [1070951136.2895_0.gmn.gmn-usa.comS=165.Mail] to remote on socket [2648]..
POP: EOD sent to remote on socket [2648], sendTCP() RC=0..
POP: (State=2) on socket [2648] Got DELE 2

POP: DELE result on socket [2648]=+OK message 2 deleted.

POP: (State=2) on socket [2648] Got DELE 1

POP: DELE result on socket [2648]=+OK message 1 deleted.

POP: Entering UPDATE state..
POP: deleting E:\XGATE\XGATE\spool\test\1070950802.2727_0.gmn.gmn-usa.comS=159.Mail..
POP: deleting E:\XGATE\XGATE\spool\test\1070951136.2895_0.gmn.gmn-usa.comS=165.Mail..
POP: Leaving UPDATE state..
POP: (State=3) on socket [2648] Got QUIT
POP: Closing connection on socket [2648]..
POP: Exiting thread for socket [2648]..


Now go to options->accounts->properties->receive
and check remember password and enter an invalid
password.

Now check for mail. iScribe gives no errors! it sits
there silently. The user is under the impression that
there is no mail. Here is the pop log from the server.
Note that an ERROR code is returned to iScribe.

POP: 09/12/2003 00:20:41-Spawning server thread for socket [2676]..
POP: Sending 'service ready' to receiver on socket [2676]..
POP: (State=1) on socket [2676] Got USER test

POP: sent OK to USER test on socket [2676]..
POP: (State=1) on socket [2676] Got PASS
POP: sent ERR to PASS on socket [2676]..
POP: Error receiving response, 0 length reply on socket [2676]..
POP: Closing connection on socket [2676]..
POP: Exiting thread for socket [2676]..

It looks like iScribe is closing the socket when it
receives the ERR code. Again it reports nothing
to the user.

One nice feature would be to have a "remember password"
check box on the "Enter password for..." dialog that
pops up asking the user for a password. This way the
user could simply enter the password and have the program
remember it with out having to navigate through the menus
to find the correct settings panel.

Thanks for your help.

--luis


fReT
09/12/2003 5:26am
I've got code to return the error from the server and display a message box.

But I do remember removing it because it got really annoying if your server was up and down all the time.

Thats why the status panel shows a little red light when the connection fails. So you can go and look into it without message boxes interfering with your work. There is a general consensus amongst UI designers that you shouldn't take the focus away from the user when they are doing something. So if the message pops up while an automatic check is taking place then the user would be very annoyed.

As for the password request window, that is for people that don't enter the password into the options at all for security reasons. They want to be prompted for the password every time Scribe runs. The rest just want it remembered for good, so they'll just set it once in the options and forget about it. So you shouldn't need a "remember password" option, just set it once in the options when you create the account.
Reply