Forum Post
Index > Scribe > .mail2 folder not showing messages after power spike and Scandisk run. Please help.

Author/Date .mail2 folder not showing messages after power spike and Scandisk run. Please help.
Devin
08/01/2004 7:54pm
Lost all mail from 1/2/03. Around 250 messages. Looking for a manual way or script/program to repair/gain access to messages. Willing to pay reasonable amount for fix. Need a fix ASAP. Running Win98.

Thanks,

Devin
fReT
09/01/2004 3:22am
I'm half way through writing a stand along program to read all the objects out of the folder and save them into a new folder. I'll let you know when its ready.
Devin
09/01/2004 7:01am
Matthew;

Thanks.
Devin
09/01/2004 2:26pm
Matthew;

Not to put a rush on you, now long do you think it will be till completion? Anything I can do to help?
Did Ims (http://memecode.com/forums/view.php?id=1601) ever get his messages back? The only reason I ask is because I desperately need a few of those e-mails with attachment.


Is there a manual way to gain access to them?



Thanks,

Devin
fReT
09/01/2004 5:47pm
I might be able to get something workable by early next week. Half the code is written..
Devin
09/01/2004 6:11pm
Matthew;

If you could that would be great. It would really help me out a lot. As always, if I can help you out anyway, donít hesitate to ask.


Thanks,

Devin
fReT
11/01/2004 7:07am
I've written all the code to scan the folders and pick out valid objects, and then tie it all back together again. I'm just stuck on the export code. It looked like the easiest bit but it turns out to be just as annoying.

Anyway. Lots of progress made, but no repair tool yet.

Next chance to code is tuesday night. I'm sure I'll wrap something up then.
Devin
11/01/2004 11:51am
Matthew;

That is great. I will check back with you on Tuesday. Just to let you know I do plan on compensating you for taking your time to help me with this matter.


Thanks,

Devin
Devin
11/01/2004 7:10pm
Matthew;


Got a quick question. Is there in way to retrieve a few e-mails out of my large mail2 file manually? I will still need the lot of them but these few I need ASAP.


Thanks again,

Devin
fReT
11/01/2004 7:46pm
I would try using a binary file search utility. The text part of the message will be readable if you can find it in amongst the data. But that requires remembering a word or phrase from the message in question. A hex editor with a search function should do the trick.

But there is no program to do that other than Scribe yet.
Devin
11/01/2004 7:53pm
Matthew;

I think I better just wait in till Tuesday. Don't want to mess anything up.


Thanks,


Devin
fReT
13/01/2004 12:21am
I've got most of the way through writing the export code now, and it's making a reasonable looking exported folders file. I just need to fix a few more things and we'll be on our way.

I'll post a link here in the next 6 hours or so.
fReT
13/01/2004 5:56am
Ok here we are. I've got something built, and tested for extracting data from broken folders.

The executable is here. Download and unzip to your Scribe directory. Then at the command line run it like this:
folder-dump folders.mail2 -s -a

This should write out a new folder file called export.mail2 in the same directory. Then I'd rename folders.mail2 to old.mail2 and rename export.mail2 to folders.mail2 so that your loading the newly created folder file. You may find dupelicate data in the new folder but at least all the links should be fine. Internally to objects there may still be corruption. This tool probably can't cope with everything yet but it's a start.

(The source code [for those that are interested] is here. Hopefully people will use it on their own folders if required and even expand it's usefulness).
Devin
14/01/2004 7:16am
Matthew;


Thanks again for working on this.


Got a little issue though. After the data is extracted I find myself with a 1.36 GIG mail2 file. The original was 445 MB. Following your directions; I rename the file and went to open it in inscribe and it does start to load it but this is where it starts to act weird, rather than loading my six or seven folders like normal, it looks like it is trying to load multiple copies of each folder, over and over again. If I try to click on one of the folders nothing shows up. It then locks-up.


I am sure is probably just a small error so if you can take a look.


Thanks,

Devin


P.S. Be on the lookout later today or early tomorrow for a Paypal transaction from me, you have been a great help in this matter.
Reply