Forum Post
Index > Scribe > IMAP

Author/Date IMAP
sb
13/01/2004 4:07pm
Like Scribe, but IMAP is only returning headers not content. Is this intentional or have I gone wrong somewhere? (I have searched posts to best of ability and checked on line manual)

If not implemented yet - any idea when full IMAP may be available?
TIA
fReT
13/01/2004 5:59pm
This should work. It has been implemented but it seems that on some servers it's not working. This is an incompatibility between Scribe and the server your using. Most likely unearthing a bug in my implementation.

All the IMAP servers I've logged into have seemed ok. But there are quite a few different server implementations getting around.
sb
14/01/2004 3:17am
Is there any extra information I can give you to help pin this down? Headers etc? I may even be able to give you a temp login to the server if that helps.
sb
14/01/2004 3:24am
.... continued

It may be I can take your findings back to the server developers to come up with a solution.
fReT
14/01/2004 3:32am
The temp login is the best bet for a quick fix. We can explore other avenues if that doesn't work.
sb
21/01/2004 7:56am
OK - will set up and let you know via direct email.
(delay due to DNS problems with nominet making mail unreliable)
fReT
05/02/2004 8:11am
I've been able to log into the account you provided and look at the problem. Basically the server doesn't support the RFC822.TEXT argument to the Imap FETCH command. Which on most normal servers will return the bodies text.

There is an equivilant argument that it does support: BODY[TEXT]. Which I've amended the program to use instead.
Reply