Forum Post
Index > Scribe > aim supported; well done :-)

Author/Date aim supported; well done :-)
pepas
28/07/2005 3:02am
Well done Fret

aim mail is supported now by iScribe. Works fine with IMAP (fetch) and PLAIN authentication.

With ALL authentication it does not work. Remaining authentication types yet to check.

IMAP (full) yet to check.

pepas
28/07/2005 3:25am
Fret

when checking for new mail, iScribe fetches all the mails once again from server and populates all the mails once again in Inbox (double entries in Inbox after second check).

so how to make it to fetch only new mails from server?.
fret
28/07/2005 3:51am
What is the "leave messages on server" option set to?
pepas
28/07/2005 3:59am
yes its checked for leave messages on the server. hence, the messages are there in server. is this the reason for fetching again all the messages?. if so, how to fetch only new mails from server? (by still leaving messages on the server).
fret
28/07/2005 4:07am
This would normally work fine. There must be something different about your setup, I gather your using test10?

Maybe it's something to do with AOL's mail server. If the unique ID's of the messages are only valid for a session at a time then you'd get this sort of problem. But I'm pretty sure AOL would make that mistake.
pepas
28/07/2005 4:29am
right fret. its test10.

I deleted everything related to receive and inbox mails. so I will setup again and get the logs while fetching. I will take some time for that and paste it here the logs.

pepas
28/07/2005 8:52am
fret

the following are the results

IMAP( Fetch) PLAIN worked
IMAP (Fetch) LOGIN worked (same problem as that of PLAIN)

IMAP (Fetch) other authentication types does not log in.

IMAP (Full) doesnot log in at all with all the authentication types tried.

(actual logs, I will post later)

I will try another IMAP mail and post here the logs. May be it will take some time.
fret
28/07/2005 9:13am
I know why IMAP(full) is not working. The UI option for login type is not connected up yet. Sorry about that, I'll fix it for the next release.
pepas
29/07/2005 3:38am
This is the log for IMAP (full) with ALL authentication.

A0001 CAPABILITY
* OK imap-d22 v43_b1.22 server ready
* CAPABILITY IMAP4rev1 LITERAL+ XAOL-ENVELOPE XAOL-NETMAIL XAOL-OPTION XAOL-FBR.OLD IDLE AUTH=XAOL-UAS-MB XAOL-FILTER QUOTA NAMESPACE
A0001 OK CAPABILITY completed
Warning: Unsupport auth type 'XAOL-UAS-MB'
Reply