Forum Post
Index > Scribe > Problem with receiving mails through SSL (using IMAP4 fetch)

Author/Date Problem with receiving mails through SSL (using IMAP4 fetch)
JP
03/09/2005 12:08pm
For some odd reason, I just cant get the program to receive emails through SSL.
Ive installed the plugin and the required DLL's and activated the SSL in account properties. But I get this error message when I try to connect in the log:

Using 'C:\Program Files\i.Scribe v1.87\ssleay32.dll'
Using 'C:\Program Files\i.Scribe v1.87\libeay32.dll'
Connected to 'xxxx.xx.xx:993' using SSL
Error 5: error:00000005:lib(0):func(0):DH lib
SSL connection closed.

I myself put the xxx's on the address...

Im starting to think, that this has something to do about SSL certificates?
Am I right, is there anyway I can get it to work?
Ive been looking for a compact email program for weeks now, and finally found a good one, and cant get it to work :(

I was going to put it on my USB stick in the future...
fret
05/09/2005 1:20am
Can you test with another SSL account?

Gmail is a good example, it's known to work. If you can't connect to Gmail then something in your config is broken, if it does work then it's something to do with Scribe's interaction with your ISP or mail server.

There are 2 types of SSL as far as I can see.
  • STARTTLS style, where you connect normally and go into SSL mode mid stream.
  • And SSL from the very beginning.


Scribe supports method #1 for SMTP/IMAP and method #2 for POP. Currently there is no way to force the use of the other SSL method in Scribe. So one thing that might be going on is that your mail server is assuming the other method than what Scribe supports. I intend to fix this soon, and supply more options on the send/receive settings tabs. I recently added overrides for the authentication system used, so a similar system might be in order.
Reply