Forum Post
Index > Scribe > Trouble sending mail over 1kb?

Author/Date Trouble sending mail over 1kb?
Timo
16/09/2005 6:52am
I don't seem to be able to send mail if it's over 1kb in size. It seems rather odd to me.. any ideas?
fret
16/09/2005 6:54am
What OS/version?

Do you have the same problem with other email clients?
Timo
16/09/2005 4:22pm
Windows 2000 (2195, sp4)
inscribe v 1.88 test12 release.. tried 1.87, had the same issue.
Seems to work fine with Mozilla mail.


220 mail.nospam.net ESMTP Sendmail 8.13.3/8.13.3; Fri, 16 Sep 2005 11:17:19 -0500
HELO default
250 mail.nospam.net Hello pppo*.nospam.net [123.456.789.10], pleased to meet you
MAIL FROM: <me@nospam.net>
250 2.1.0 <me@nospam.net>... Sender ok
RCPT TO: <me@nospam.net>
250 2.1.5 <me@nospam.net>... Recipient ok
DATA
354 Enter mail, end with "." on a line by itself << long pause here

SocketError(10054): Connection reset by peer.
Timo
16/09/2005 8:30pm
I tried again, with a new mail store. Same issue, it seems.
Timo
17/09/2005 12:28am
from scribe.txt

Send(0) got 2 mail to send
Send(0) connecting to SMTP server
Send(0) connected
Send(0) Item(0) starting send
Send(0) Item(0) failed: SendEnd failed
Send(0) posting WM_SCRIBE_THREAD_ASK
Main(0) WM_SCRIBE_THREAD_ASK start, receive=0
Main(0) WM_SCRIBE_THREAD_ASK end, receive=0
Send(0) closing
Send(0) exit
Timo
27/09/2005 2:24pm
test13 seems to have the same issue, unfortunately.
fret
28/09/2005 1:55am
I know. I havn't changed anything that would fix that, mainly because I don't know whats causing the problem. Most of the logs you have sent me indicate that Scribe is behaving normally but the connection to the server just dies at some point. To be honest, I suspect the server is not behaving correctly.

However, other email clients work fine right? So it could be some inter-dependency between these 2 exact peices of software. The next stage of debugging is to get some logging code into the sending code, and get you to run a test build. Which I will get around to doing over the next few days... give or take.

The test13 release was needed to get various fixes out to other users.
Timo
28/09/2005 3:31am
Yes, Mozilla mail works fine. Unfortunately, I don't have access to another smtp server to test inscribe with. =/
fret
28/09/2005 4:10am
The groupware module for Scribe can act as an SMTP server. And at some point I'll added end-to-end SMTP support to Scribe so that it can bypass your ISP's SMTP server and deposit mail directly into the recipient's server.

The SMTP server in the groupware requires a fully fledged net connection to work, so if your firewalled off then it isn't going to help. If you need help configuring it let me know.
Timo
28/09/2005 4:22am
I have a cable/dsl router that also functions as a firewall, if I am not mistaken. Can you tell me which protocols and ports to open in order for it to function correctly?
fret
28/09/2005 4:25am
The SMTP server will try and connect out on port 25 to send email. It will also need to do DNS lookups on port 53.
Reply