Forum Post
Index > Scribe > Unable to connect to Imap server

Author/Date Unable to connect to Imap server
Ravi
23/11/2005 4:37am
Hi,
I have recently downloaded the i.scribe v1.88 Test13 Release (Build Sep28 2005).
I always get the time out and the log says Resource temporarily unavailable while connecting to the IMAP server.
I tried both Imap (Full) and Imap(fetch).
The log is pasted below.

-Ravi
---------------------------------------------------------------------
A0001 CAPABILITY
* OK Microsoft Exchange Server 2003 IMAP4rev1 server version 6.5.7226.0 (BLRKECMSG12.xx.xxxxx.com) ready.
* CAPABILITY IMAP4 IMAP4rev1 IDLE LOGIN-REFERRALS MAILBOX-REFERRALS NAMESPACE LITERAL+ UIDPLUS CHILDREN AUTH=NTLM
A0001 OK CAPABILITY completed.
A0002 AUTHENTICATE NTLM
+
TlRMTVNTUAABAAAAB7IAAAsACwAgAAAAAAAAAAsAAAByYXZpX25hbGxhbg==
+ TlRMTVNTUAACAAAAFAAUADgAAAAFgoECgaoj8IU+FaMAAAAAAAAAALYAtgBMAAAABQLODgAAAA9JAFQATABJAE4ARgBPAFMAWQBTAAIAFABJAFQATABJAE4ARgBPAFMAWQBTAAEAGgBCAEwAUgBLAEUAQwBYAEMATAAwADIAQQAyAAQAHABhAGQALgBpAG4AZgBvAHMAeQBzAC4AYwBvAG0AAwA4AGIAbAByAGsAZQBjAHgAYwBsADAAMgBhADIALgBhAGQALgBpAG4AZgBvAHMAeQBzAC4AYwBvAG0ABQAcAGEAZAAuAGkAbgBmAG8AcwB5AHMALgBjAG8AbQAAAAAA
TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAABQAFABwAAAAFgAWAIQAAAAWABYAmgAAAAAAAABwAAAABYKBAsLUE9aC3/7dI2/9PMD3ier1CZOPY9ZksTv3AG72A5+bebYzWfVubKliJYQkBZDVvUkAVABMAEkATgBGAE8AUwBZAFMAcgBhAHYAaQBfAG4AYQBsAGwAYQBuAHIAYQB2AGkAXwBuAGEAbABsAGEAbgA=
A0002 OK AUTHENTICATE completed.
A0003 AUTHENTICATE NTLM
A0003 BAD AUTHENTICATE command received in invalid state.
TlRMTVNTUAABAAAAB7IAAAsACwAgAAAAAAAAAAsAAAByYXZpX25hbGxhbg==
TlRMTVNTUAABAAAAB7IAAAsACwAgAAAAAAAAAAsAAAByYXZpX25hbGxhbg== BAD Protocol Error: "No space following tag in IMAP command".
TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAAAwAAAAFgAWAHAAAAAWABYAhgAAAAAAAABcAAAAAAAAADFhnmhsKghsGEdNmuo50qBmIE/ddOdWxPwTdTrcDdt6t4ATpseUDwG+Yd6vJt95inIAYQB2AGkAXwBuAGEAbABsAGEAbgByAGEAdgBpAF8AbgBhAGwAbABhAG4A
TlRMTVNTUAADAAAAGAAYAEAAAAAYABgAWAAAAAAAAAAwAAAAFgAWAHAAAAAWABYAhgAAAAAAAABcAAAAAAAAADFhnmhsKghsGEdNmuo50qBmIE/ddOdWxPwTdTrcDdt6t4ATpseUDwG+Yd6vJt95inIAYQB2AGkAXwBuAGEAbABsAGEAbgByAGEAdgBpAF8AbgBhAGwAbABhAG4A BAD Protocol Error: "No space following tag in IMAP command".
SocketError(11): Resource temporarily unavailable.
fret
23/11/2005 4:46am
I think you should try test15, I believe this might be fixed already.
Ravi
23/11/2005 5:14am
I dont know how, but when I select the authentication type as 'all', it is connected.
But this time I don't get the sub-folders and their messages, under Inbox from my Imap server.
So I tried Imap Full and it is showing me all the folders on my Imap. and now a new problem has come up.
Even if I leave the app idle I get an error window:

------- Debug --------
Assert failed: Code/ScribeMail.cpp, line 4070
0
--------
and on the terminal I find,
-----------
Code/ScribeMail.cpp:4070 - Assert failed:
0
Didn't get css for 'td#td1'
Didn't get css for 'td#td2'
Didn't get css for 'td#td3'
-----------

and the app crashes,

let me know how to resolve this. I think I have read that Imap Full is a bit buggy. If it is, then let me know how to fetch my folders from the server using Imap fetch.
thanks,
-Ravi
fret
23/11/2005 5:17am
Console?

Are you using the linux build?
Ravi
23/11/2005 5:46am
Did I surprise you by saying terminal.
Sorry I forgot to mention I use Linux (Redhat EL). and I didn't find Test15 for linux. So I downloaded the RC3 from the Downloads section ( which seems to be an older build than the previous, RC3, build May 11). But this one's seems stable with Imap full.
But the trminal is clogged with messages like,
GFile::Open failed
open(Picture(12).jpg,00000000) = -1
errno=ENOENT (No such file or directory)
GFile::Open failed
open(Picture(11).jpg,00000000) = -1
errno=ENOENT (No such file or directory)
..
may be it is trying to fetch the images and attachments,
Also I note a lot of the messages are marked deleted on the server, I don't know why?

.
I use mutt ( infact a hacked version of muttng), but my teammates send lot of appointments which are in vcal or ics format. That is why I wanted to shift to I.scribe. I also learnt that you had a LDAP plugin, I thought I can use that to fetch the contacts from the Exchange server for auto completion ( which I have already configurd in mutt).
Help me in using i.scribe, the lsap plugin wwhen I try to load gives the error:
GLibrary::Load("/usr/local/apps/scribe-linux/scribe-ldap/libscribe_ldap.so") failed.
libldap.so.201: cannot open shared object file: No such file or directory
thanks,
-Ravi

fret
23/11/2005 5:50am
I fixed the IMAP login thing in test14, so I'll have to do a new build for Linux.

The ldap thing maybe because I build on RH9 which is kinda ancient now and I don't know enough about the whole shared library thing on Linux.
Reply