Forum Post
Index > Scribe > test11

Author/Date test11
test11
05/04/2007 3:49pm
showing wrong received times!!!!!!!!!

wtf???????????????
fret
05/04/2007 9:08pm
Can you give an example of this?

Include the "date:" header and what timezone you are currently in, and if you are in daylight savings time.
BAR
11/04/2007 2:00am
This problem seems to have started between the 8th & 12th of March this year (based on looking at some emails showing offsets between the displayed time and the correct time shown in the header). Maybe related to the date & time fixes mentioned in version 12?
fret
11/04/2007 4:52am
Sorry I was thinking about the sent date.

Ok, did you change the timezone setting on your computer?

Scribe might not handle that correctly. I'll look into that.
fret
11/04/2007 5:17am
Ok I've confirmed there is a problem with changing timezones. The "receive date" on the email is in local time which means when you change timezone it doesn't update correctly.

Soooooo... what needs to happen is for me to start storing the date in UTC and covert it to localtime just when I need to display it. That way it'll be correct in whatever timezone your computer moves to.

I will code that up tonight... shouldn't be hard. Just a matter of defining a new field ID for "receive date UTC", writing the serialization routines and testing.
BAR
03/05/2007 12:51am
Any news on this prolem? I'm getting tired of seeing messages sent to me from the wrong time!
fret
03/05/2007 4:06am
If you're having a problem with mail just received then it's not the same problem I'm talking about in my previous post.

Seriously if you want to get help with this, then please post an example message, including the date field from the internet headers and the data that Scribe displays, AND the current timezone settings for the machine your running on.
BAR
04/05/2007 5:05am
I've sent what you've asked for by e-mail; also enclosed a snapshot of the correct times displayed by another client (which were correct).
Reply